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Prerequisites

▪ StarTracker with lens data input, UDP support and minimum firmware version 2663
▪ PC with minimum Intel I7 and Nvidia GTX 1080 (RTX 2080TI for ray-tracing) or equivalent.
▪ Secondary HDMI monitor.

▪ Blackmagic or AJA SDI capture card with at least one SDI input and one SDI output. E.g. Decklink Quad
2 or Corvid 88 (For laptop use, these can be connected via thunderbolt 3 e.g. Sonnet PCI expansion)

▪ Camera with SDI output and sync (Genlock) input.
▪ Sync Generator with multiple outputs e.g. Mini Converter Sync Generator
▪ SDI recorder (Optional) e.g. HyperDeck Studio Mini
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Hardware

▪ Blackmagic Decklink 12.1 Desktop Video
▪ Windows 10 64-bit (Pro preferred)
▪ Latest Nvidia drivers

▪ Epic Games Launcher
▪ Latest available version of Unreal. For previous versions of Unreal please contact support@mo-

sys.com
▪ Unreal Engine Marketplace Plugins: Mo-Sys VP Free
▪ Teamviewer 14+ (For remote support)
▪ Bonjour or Apple Itunes, this allows automatic detection of StarTrackers from the Unreal Engine
▪ TightVNC
▪ Aja control panel
▪ WinSCP
▪ Latest visual studio 2019

• Note: If running at 25p, 50i or 50p it is recommended to set your graphics card display(s) to 50fps.
(Right-click Desktop > Display Settings > Advanced Display Settings > Display adaptor properties for
Display X > List All Modes)

Software

https://software.mo-sys.com/downloads/StarTracker/r2663%20BCN/r2663%20BCN.zip
https://www.blackmagicdesign.com/uk/products/miniconverters/techspecs/W-CONM-15
https://www.blackmagicdesign.com/uk/products/hyperdeckstudiomini/techspecs/W-HYD-07
https://www.blackmagicdesign.com/uk/support/family/capture-and-playback
mailto:support@mo-sys.com
https://support.apple.com/kb/DL999?locale=en_US
https://www.tightvnc.com/download.php
https://www.aja.com/products/aja-control-room
https://winscp.net/eng/download.php
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▪ Create a new project “With Starter Content”
▪ Select “Create a New Blank Unreal project” then click on next

▪ Select “Blank” then click on next

▪ Add “Starter Content” then click on create project

www.mo-sys.com

Creating a new project
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There are two ways to install the Mo-Sys VPPro Plugin.
The first option is the preferred option.

Plugin Installation Example

www.mo-sys.com

Installation
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▪ When you have created a new project, you can drag and drop the plugin folder “MoSysVPPro” into the
unreal Project folder. If the Plugins folder doesn’t exist, please create a new folder for Plugins then
drop the plugin inside the Plugins folder

▪ For each new project, you will need to drop in the MoSysVPPro plugin into the Plugins folder.

Option 2: All Projects

▪ If you want the MoSysVPPro plugin across all projects, you will need to drag and drop the plugin into
the Plugins folder where you have installed Unreal Engine 4.25. E.g <UE4.25 installation
folder>\Engine\Plugins

Option 1: Per Project
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Once you have placed the Plugin inside the Plugins folder. Launch the project file. You will go to Edit ->
Plugins and confirm that the Mo-Sys VP Pro plugin in enabled. Once it is enabled, restart the editor.

www.mo-sys.com

Installation
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Modes of Operation
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▪ VFX mode is internal keying with SDI in and 

optional SDI out

▪ Augmented Reality mode is SDI in and optional SDI out 

where all graphics lies in front of the live video

▪ Pre-keyer mode provides dual SDI out (fill 

and key signals) to an external keyer

▪ Post-keyer mode receives dual SDI in (fill and key 

signals) from an external keyer for internal 

compositing
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Modes of Operation
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▪ Mode, frame rate and other settings are available in Edit > Project Settings > Plugins > Mo-Sys VP Pro

▪ To change frame rates - only change it in the VP Pro settings and then restart the engine to ensure the 
frame rates match everywhere.
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Internal key in VFX mode
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• If you click on the camera, you can find ChromaKey and compositing in the details panel.

• Multiple parameters can be tweaked in order to pull the key including colour correction and despill. You can use 

the check boxes under Compositing to aid with this.
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Usage

▪ To configure the Mo-Sys VP Free plugin, please refer to the instruction in the manual and example
project on the marketplace.

▪ You can change the “Default Live Link Present” name by editing 
the settings.
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Mo-Sys VP Free Plugin

Mo-Sys VP Free Live Link Presets

▪ If you name your Live Link preset as “MoSys” when saving it, your preset will be automatically loaded
when you restart Unreal Engine.

▪ To save the Live Link preset, open up Live Link and click the dropdown arrow on Presets, and a window
should come up.

▪ At the top, it will say “Save as Preset”, name the preset “MoSys” and hit save

https://software.mo-sys.com/docs/MoSysVPFree/VP%20Free%204.27.pdf
https://www.unrealengine.com/marketplace/en-US/product/mo-sys-tracking
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Mo-Sys VP Pro Plugin 

Quick Start Guide
▪ Open the “StartTrackerSetup” map from MoSysVPPro Content / StarterContent / Maps.
▪ If you are not able to find the MoSysVpPro content, please go to the bottom right, Click view options ->

Show plugin content
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▪ Open the MoSysSetup layout.
▪ Use AR Mode.
▪ Open the “Live Link” panel then follow the instructions in the manual in order to:

▪ Add a source
▪ Add Subject Name
▪ On the MoSysCameraARs MoSysLiveLinkComponent, select the subject name

▪ Open the StarTracker Panel, select your “Live Link” source, then click on “Auto-Configure”
▪ Ensure you are sending F4 status from the StarTracker (Data > Advanced > F4 Status) to receive tracking 

status in Unreal.
Now, “Tracking Data” in the status panel should turn green. The “Lens Distortion” will turn green as well
if you have lens data.

https://www.mo-sys.com/downloads/MoSysVPFreePlugin-GettingStartedGuide.pdf
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▪ Video Controller Panel can also be used to view the video in/out
▪ Now, the colour of the “Video” in the status panel should turn green.

www.mo-sys.com

Mo-Sys VP Pro Plugin

Take Recorder
▪ To record and export camera data, Use the Take Recorder. Make sure that the Take Recorder panel is

opened in the editor level. The new MoSysLive layout will enable you to prepare your editor for
recording.
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Synchronization

▪ Use the MoSysTimecodeSynchronizer to synchronise the tracking data with the video. For more 
details, see Timecode Manager panel or Timecode Synchronization.

▪ If all the previous steps were followed correctly, then all of the statuses in the status panel should 

turn green
▪ Note: In Pre-Keyer mode (with Blackmagic video card) you must have video in for the Blackmagic 

Custom Timestep to work.

Enable Video

▪ If the video assets are not created when you restart your project in AR mode, then you can use the
video controller panel to generate them, by clicking on "Recreate Assets". After that you may need to
restart your project.

▪ Open the MoSys fill view port, by clicking on Window > Viewports > Fill Output
▪ Set the "Viewport Type" to "Mo-Sys Fill Output"

https://mosys-my.sharepoint.com/:p:/r/personal/patrick_mo-sys_com/Documents/VPPro%20Manual%20v3.pptx?d=w685a743ca86948689247db48ccd856b3&csf=1&web=1&e=g7qERj&nav=eyJzSWQiOjI4MSwiY0lkIjoxMDI4OTc2NzAzfQ
https://mosys-my.sharepoint.com/:p:/r/personal/patrick_mo-sys_com/Documents/VPPro%20Manual%20v3.pptx?d=w685a743ca86948689247db48ccd856b3&csf=1&web=1&e=6O5qBw&nav=eyJzSWQiOjI5MCwiY0lkIjoxNjIzMDMyNzQ3fQ


www.mo-sys.com

Mo-Sys VP Pro Plugin
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▪ Select “Reset Take Recorder” from the “MoSys” tool bar. This will set up the Take Recorder panel to
record all actors with a Mo-Sys LiveLink component.

▪ Open the level blueprint from the editor. In the Event Graph, hook up the space bar event to the
‘Start/Stop MoSys Recorder’ node. Click on “Compile” then “Save”.

• Now you will be able to start and stop recording using the space bar once you hit play, the mouse will be
captured automatically (this can be disabled on the MoSysCamera). To release the mouse, the shortcut is
Shift+F1.
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Mo-Sys VP Pro Plugin
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▪ Stopping record will time-stamp the take with the start timecode.

▪ Follow these steps in order to Export to FBX
▪ Click on “Locate” in the Take Log panel, the content browser where your recording resides will open.
▪ Open it by double click, it will show in the “Sequencer”.
▪ In the “Sequencer” you can export as an FBX to a specific location on our device.

Exporting Takes Data

https://gitlab.mo-sys.com/root/catena/uploads/fee54a517e91ac8fdf4f3552579c499a/image.png
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Mo-Sys VP Pro Plugin
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▪ Choose the folder where you want to save the FBX file, name your files, then click “Save”.

▪ Set the “FBX Export Options” then hit “Export”.

https://gitlab.mo-sys.com/root/catena/uploads/63edb4c6701bcb427dbd239bbdb187c9/image.png
https://gitlab.mo-sys.com/root/catena/uploads/982b194f06041e96041e792260d33957/image.png
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Custom Metadata
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▪ Using simple blueprint as shown you can add custom timecode-stamped metadata to each take.
This can be used to capture specific lens distortion details, animation triggers or any other
information that you want to preserve through to post-production.

▪ Note: 'If you provide a Camera Name the custom metadata will only be appended to the .txt
metadata file associated with that MoSysCamera
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Render Movie with Lens 
Data
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▪ To render movies with Lens Data enabled, navigate to the Sequencer Copy Cameras in the World
Outliner. Sequencer cameras are marked with a lightning symbol. From there, select the
DistortionBlueprint (UndistortBlueprint if using AR) and apply the filter with 'Use Live Distortion' and
disable this value before doing a render.
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Mo-Sys VP Pro Plugin
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• Genlock in the engine is called the Custom Timestep. It will be configured automatically by
the plugin based on your video card. If you want to override it with your own timestep you
can do this with the "Configure Genlock" button in the Video Controller

• The green bar in the Genlock window shows how much of the frame is being used to render.
If the bar fills up then you will start to see drop frames and will need to optimise the
performance of your scene.

Genlock
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MSVP Panels

MSVP (MoSysVP) comes with panels inside Unreal Engine 4. This is where you will find panels such as
Status, StarTracker View, Video Controller, Take Log, Time Code Manager, Arri Camera Control, and
Stage Manager.

▪ You can locate these panels under the Window tab or on the Toolbar with the Mo-Sys logo.
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Status

▪ To check the status of different elements of the status panel, hover over them and a text will be
displayed on the bottom of the panel. This will help you diagnose issues with your system.
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MSVP Panels
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StarTracker View
▪ This Panel enables the user to control some of the key features of the StarTracker Hardware. It

automatically detects and adds the StarTrackers that are on the same network to the panel. It also
shows information about the detected StarTracker, including its hardware ID, IP address, and the
currently used lens file. It also displays the status.

▪ Once you select the live link source in the panel, the Auto-Config button will be enabled. If you click
Auto-Config, the StarTracker’s IP address and port will be changed to match the ones in the LiveLink
Source. You can also change the lens file in the StarTracker by selecting one from the Lens drop box

in the panel.

▪ For more options, you can always invoke the StarTracker Engineering interface, by clicking on “VNC”
button.
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MVSP Panels
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▪ The Video Controller allows you to monitor and configure video input and output.
1. The colour of Video in the status should turn green one you’ve video in.
2. If you click on “Recreate Assets”, video assets will be created in your games /MoSys folder.
3. You can edit input/output media player sources when you click on “Configure”.
4. Input Media player can be opened if you click on “Open Player”.
5. If you have an SDI input with different settings than the default ones of the video controller

e.g. (1080p25), you can edit source to match your input.

Take Log

Video Controller

▪ This will show information about the recorded takes and scenes. (NOTE: This feature is still in beta.)
1. Click on the date button to show the recordings performed in a specific day.
2. Refresh will update the panel.
3. This section shows the time code, take number and scene number, respectively.
4. To view or to locate the takes, click on “Open” or “Locate” buttons.
5. “Export All” will export the take log as text file to the specified location in your device. You

can also export files individually.
6. Record button enables you to start/stop
recording
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MVSP Panels
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Time Code Manager

▪ This Panel enables the user to manage the synchronization via timecode of LiveLink subjects
(StarTracker) and video sources. This panel lists the video inputs for the current mode along with
every LiveLink component in the scene. On the left is the Media Source name or the current Subject
Actor of each LiveLink component. You can control timecode offsets and instruct an associated
StarTracker to "jam" against the engine.

1. If the Synchronizer is synchronized, the panel’s status (on the bottom right) will change to
synchronized and will also display the frame rate.

2. This section will show the TimeCode buffer of the sources (min – max). If you hover over the
pause button on the bottom left, you can freeze time code value. You will see the same for
the video input source when synchronized.

3. In order to jam a source, click on jam button or use Jam All.
4. You can adjust TimeCode offset of the StarTracker.
5. To start\stop synchronization
6. The refresh button will update the panel to reflect new/removed LiveLink components and

video inputs for the current mode
7. You can Enable\Disable the Synchronization sources using the checkbox.

Note: The decrement/increment and Jam button will not be enabled if a LiveLink Subject has not been
associated with the relevant StarTracker in the StarTrackers Panel

https://mosys-my.sharepoint.com/:p:/r/personal/patrick_mo-sys_com/Documents/VPPro%20Manual%20v3.pptx?d=w685a743ca86948689247db48ccd856b3&csf=1&web=1&e=OTP1vz&nav=eyJzSWQiOjI3OSwiY0lkIjoyNjc2NTc4OTF9
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MVSP Panels

21

Arri and Sony Camera Control

▪ If your production is using a camera that supports CAP (Camera Access Protocol), You can
communicate with the camera directly over Ethernet or Wi-Fi and receive live metadata in the Arri
or Sony Control Panel.

▪ Open the panel from the Window menu or using Mo-Sys Toolbar menu. Connect the camera by
providing the camera’s IP address and password (the password can be found in the camera’s menu –
the default for Arri cameras is ‘arri’)
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MVSP Panels
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Arri and Sony Camera Control
▪ Once connected, you will see the Arri interface. This will update live with the camera parameters. If

you are using the Take Log, the camera metadata will also be captured at the start of the take and
added to the text file that is exported from the “Take Log”
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MVSP Panels
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Arri and Sony Camera Control

▪ To listen to camera events, implement the Mo-Sys Camera Settings Interface in your blueprint, and
override the appropriate event node. This example shows how you might connect the Arri’s “Is
Recording” signal to trigger data recording in the “Take Recorder”
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MVSP Panels
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Arri and Sony Camera Control

▪ The following blueprint implements the same goal for Sony cameras
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MVSP Panels

Stage Manager
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▪ The stage manager panel enables the user to move their stage, depending on their perspective in
the editor.

▪ In Order to use it, go to the editor, change the viewer’s perspective then click on “Drop Stage”, this
will shift the stage to the new perspective viewed in the editor.

▪ The position of the new stages will be saved, enabling you will load all the stages that you have
previously dropped.
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MSVP Layouts

Pre-Loaded Layouts
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To switch between the different layouts, click on Window > Load Layouts then select your layout.
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MSVP Layouts
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MoSysSetup

▪ This layout will enable you to get tracking data, lens distortion and video inside Unreal. Tracking data
can be achieved by setting up the LiveLink, and the StarTracker panels. To get video in, the Video
controller panel used to set up the Input and Output. The status of video and tracking in the status
panel will display green colour if the Tracking and Video were set up correctly.

MoSysRecord

▪ This will show the Take Recorder, Status, TakeLog, and StarTracker panels, enabling easy recording
for actors in the scene that have been added to the Take Recorder panel.
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Garbage Mattes and FOV

Mo-Sys VP Pro has an actor inside Unreal Engine for Garbage Matte. You can find it under “Mo Sys” actors
category. See photo below for example. You can drag and drop the Matte into the scene.
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Any object in the scene can be made Garbage by setting it's Custom Depth to 253.
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Garbage Mattes and FOV
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Select your output video mode in the MoSysCameraVFX details. Hover over each option to see a description.

FOV: (This is for non-AR cameras) If you don't have lens encoding, set the Field Of View of camera to 

match the real lens. This can be calculated (using online tools/apps since the lens focal length and image 

sensor size are known) otherwise using the eyes. Place a virtual object on the real floor and pan from frame 

left to right, adjusting the Field Of View until the object does not slide around.
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Shadows In AR Mode
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▪ AR mode has normal and shadow lights, enabling 

to light an object separately from the shadows. 

This can be found in the "ARSample" level.

▪ You can observe the shadows in the editor by selecting the “Object for calibration” in the scene or in the 

world outliner, then search for “Lighting Channels” in the detail, then check “Channel 1”.

▪ The shadows are also observable when playing in editor when “Channel 1” is checked or unchecked.
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TimeCode Synchronization

This section covers how to get StarTracker, the engine and the camera all using the same Timecode and to
use the Timecode Synchronizer in Unreal Engine to better align frames.
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▪ Camera should be outputting Timecode

▪ It's recommended to switch to the Windows > Layouts > MoSysSetup layout in Unreal Engine

▪ In the plugin settings ensure "Has Timecode Sync" is checked. Restart the engine and "Generate" assets 
from the "Video Controller" panel. This ensures the media assets are correctly prepared to receive 
timecode and to be sychronized.

▪ In Unreal Engine, open the "Timecode Manager" panel which is explained in detail here: Timecode 
Manager Panel

▪ The checkboxes on the right of the panel control which sources will currently be attempted to be 
synchronized

▪ Only check the video sources and start synchronization. (Note: Refresh in the Video Controller panel will 
also refresh + start sync for the Timecode Manager panel)

▪ The status at the bottom right of the panel will say Synchronized. In the Timecode Provider panel, you 
should see the engine timecode as the same as the incoming video source (Camera timecode)

▪ Now use the jam button to instruct the associated Startracker(s) to jam against the engine. If the Jam 
button is not enabled, then be sure you have selected the correct subject for the StarTracker in 
the StarTracker Panel

▪ Now that the StarTracker and camera are jammed, if both are Genlocked, you do not need to re-jam 
them unless you turn off the camera or Star Tracker.

▪ The timecode values for the LiveLink source(s) should now be the same (or very close) to the video 
timecode. Pause the Timecode Manager panel to assess this via the pause icon in the bottom left

▪ Adjust Timecode offsets by increment/decrement buttons or directly editing the number field for the 
LiveLink source

▪ Once the video timecode lies comfortable in the middle of the min-max buffer of the LiveLink source(s) 
then enable them by checking the checkbox on the right of the panel

▪ Stop and Start sync to attempt to synchronize the video and LiveLink source(s) (StarTracker)

▪ Bottom right of the Timecode Manager panel will display the state and synchronized framerate. All 
synchronized sources will have a Green status indicator to the left. Check the Mo Sys Status panel and 
the Sync status should also be green. Hover over to see the issue if it's not green

https://mosys-my.sharepoint.com/:p:/r/personal/patrick_mo-sys_com/Documents/VPPro%20Manual%20v3.pptx?d=w685a743ca86948689247db48ccd856b3&csf=1&web=1&e=tHHovQ&nav=eyJzSWQiOjI4MSwiY0lkIjoxMDI4OTc2NzAzfQ
https://mosys-my.sharepoint.com/:p:/r/personal/patrick_mo-sys_com/Documents/VPPro%20Manual%20v3.pptx?d=w685a743ca86948689247db48ccd856b3&csf=1&web=1&e=OTP1vz&nav=eyJzSWQiOjI3OSwiY0lkIjoyNjc2NTc4OTF9
https://mosys-my.sharepoint.com/:p:/r/personal/patrick_mo-sys_com/Documents/VPPro%20Manual%20v3.pptx?d=w685a743ca86948689247db48ccd856b3&csf=1&web=1&e=7kSuYR&nav=eyJzSWQiOjMwOSwiY0lkIjoxNTk0MDk4NjU4fQ


www.mo-sys.com

Timed Data Monitor (Beta)

The Time Data Monitor is an alternative method in which you can sync your sources together. This is an
Unreal Plugin from Epic Games so you must navigate to the plugins menu, and search for 'Time Data
Monitor' and ensure it is enabled. Once you have enabled it, the engine will prompt you to restart the
editor.
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After a restart, you can open the timed data monitor window from the toolbar Window > Developer Tools
> Timed Data Monitor. This will automatically detect any live link and video sources that are active.

For more information on using the Timed Data Monitor to synchronize your sources, please read the
official documentation from Epic Games:
https://docs.unrealengine.com/en-US/WorkingWithMedia/TimedDataMonitor/index.html

https://docs.unrealengine.com/en-US/WorkingWithMedia/TimedDataMonitor/index.html
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nDisplay
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Mo-Sys nDisplay integration moved to VP Free plugin:
https://www.unrealengine.com/marketplace/en-US/product/mo-
sys-tracking

https://www.unrealengine.com/marketplace/en-US/product/mo-sys-tracking
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Multi-Engine
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Multi-Engine enables you to broadcast bytes between different engines.
To set it up go to Project Settings > Mo-Sys VP Pro > Multi Engine. If you want your PC to be the 
Master check the Multi Engine Master check box.
Add the IP adresse(s) of the engines where you want to broadcast to.

Use the following blue print in the master engine in order to broadcast to the follower engines 
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Multi-Engine
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In the follower engines, in order to receive the byte broadcasted by the master, use the following blue 
print.

The "Event On Received Multi Engine Broadcast" can be created as an interface, by following the steps 
in the next image: Click on class setting, then add "Mo Sys Multi Engine Broadcast Interface"
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Mo-Sys VP Remote
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Installing VP Remote

In order to enable the Unreal server, you'll need add DefaultBindAddress in your project's 
DefaultEngine.ini

You'll also need to run a python flask server, that serves the html page for the interface:
From inside the "MoSysVPPro\Content\Remote" folder, you'll need to double click on "run_server.bat"

If the .bat script did not work you'll need to create a python virtual environment then run the python 
server by following the steps:
• Open a power-shell window on the same folder then run the following commands:
python3 -m venv venv
.\venv\Scripts\Activate.ps1
pip install -r requirements.txt
python3 -m swagger_server

Now open a browser in your Ipad then visit http://192.168.0.35:8080/, where 192.168.0.35 is the 
IP address where your python server is running.
Note: Make sure to run the python server inside the Master Engine
If all the steps were followed correctly you should be able to see the Ipad interface:

Prerequisites:
• python3

http://192.168.0.35:8080/
https://www.python.org/downloads/release/python-391/
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Mo-Sys VP Remote
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Using VP Remote

1- Part 1 shows the statuses of the master and the follower engines
2- You can use section 2 to begin/stop play, start/stop recording, make sure that Master and follower 
engines are ready to record, by opening the take recorder and then resetting the take recorder
3- This section will enable you to change streaming levels while you're in play mode
4- This section will enable you to trigger custom blue prints inside unreal (in play mode), this will be 
explained in the next section

Setting BluePrint Triggers in unreal

The following BluePrint shows how to set the triggers in Unreal, this needs to be done in the master 
and the followers.
When you're in play mode, if you click in the Ipad on
mumber 1 or 9 the corresponding blueprints will be
triggered in Unreal (same this can be done for the rest
of the numbers)
In order to add the Trigger events, you'll need to click
on "Class Settings" in the level BluePrint, then add
"Mo Sys Headless Interface"
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Troubleshooting

To confirm video input and format, use the relevant provider’s tools (Blackmagic Media Express or AJA
Control Panel)

If you find that you keep having to adjust the delay, then make sure that both the camera and the
StarTracker are genlocked correctly.

To confirm tracking data, look in the LiveLink window for the status of your source (e.g ‘Optical Good’). If
you don’t see data (Status is ‘Waiting’) this is most commonly a networking issue. Check StarTracker’s
network settings, confirm you can ping StarTracker and vice versa and disable firewalls.

For more information on errors, open the Output Log. You can filter to show Errors, or filter by
LogMoSysVirtualProduction or LogMoSysTracking to see plugin-specific issues.

If it does not seem like the StarTracker is jamming when clicking the Jam button, then VNC to the
StarTracker from the StarTrackers panel and make sure the UDP Src corresponds to the correct destination
IP of the engine (generally should be 1). Clicking Jam from the StarTracker will inform you if it was success
at the bottom. On the end of Sync row, you should see the timecode being output from StarTracker.
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